Jump to content
UnitySpain

Argo214

Fosiles
  • Content Count

    54
  • Joined

  • Last visited

Community Reputation

1 Neutral

About Argo214

  • Rank
    Usuario

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Pues parece que puede ser la solución. Es un poco raro pero parece que funciona. Voy a probarlo en varios dispositivos y os cuento.
  2. No, sólo está instanciado en el plano donde se proyecta la cámara. En el móvil se ve bien hasta que pulso en el botón para ir a otro nivel y ahí es donde se congela y se sale del juego.
  3. Lo siento. Me urge mucho dar con la solución. No lo volveré a hacer. No. Cambio de escena con Application.LoadLevel mediante un botón Funciona bien en el editor con la webcam del pc y en el teléfono también se ve. El problema viene al pasar a la segunda escena, que en el teléfono se sale del juego. En el pc sí carga bien la segunda escena. Testeando cosas he visto que si elimino la script "cameracontroller" el teléfono carga bien la segunda escena, por lo que deduzco que el problema debe provenir de esta script. La cámara tiene asociada un plano como child que es en el que se proyecta la imagen, y en ese plano asigno la script anterior. El error que me aparece cuando se sale del juego es el que he puesto en mi primera entrada.
  4. Tengo la 5.3.5f1 El error proviene de esta script, pero no sé la causa: using UnityEngine; using System.Collections; public class CameraController : MonoBehaviour { public WebCamTexture mCamera; public GameObject plane; void Start () { plane = GameObject.FindWithTag ("PlayerCam"); mCamera = new WebCamTexture (); plane.GetComponent<Renderer>().material.mainTexture = mCamera; mCamera.Play (); } }
  5. Estoy intentando que la imagen de la cámara del teléfono se proyecte sobre un plano en 2 escenas de un juego (como si fuera una pantalla de cine). Estoy usando WebCamTexture. Todo funciona bien en el editor de Unity pero cuando lo hago en mi android al cargar la segunda escena el juego se sale. La script que he añadido al plano donde proyecto la cámara es: using UnityEngine; using System.Collections; public class CameraController : MonoBehaviour { public WebCamTexture mCamera; public GameObject plane; void Start () { plane = GameObject.FindWithTag ("PlayerCam"); mCamera = new WebCamTexture (); plane.GetComponent<Renderer>().material.mainTexture = mCamera; mCamera.Play (); } } Agradecería mucho que alguien me echara una mano para resolverlo. Gracias!
  6. Hola! Mi juego android se sale cuando cargo una nueva escena. Cuando lo hago en el editor de unity todo está ok y carga bien el otro nivel. Este es el error que me aparece en el Android Decide Monitor al testarlo. Me podéis echar una mano para resolverlo? 09-28 14:04:24.343: A/libc(31857): Fatal signal 11 (SIGSEGV), code 1, fault addr 0x9c in tid 31879 (UnityMain) 09-28 14:04:24.486: W/ActivityManager(847): Force finishing activity 1 com.asm.NETPOINTBOA/com.unity3d.player.UnityPlayerNativeActivity 09-28 14:04:24.575: W/InputDispatcher(847): channel '35106e3 com.asm.NETPOINTBOA/com.unity3d.player.UnityPlayerNativeActivity (server)' ~ Consumer closed input channel or an error occurred. events=0x9 09-28 14:04:24.575: E/InputDispatcher(847): channel '35106e3 com.asm.NETPOINTBOA/com.unity3d.player.UnityPlayerNativeActivity (server)' ~ Channel is unrecoverably broken and will be disposed! 09-28 14:04:24.578: I/WindowState(847): WIN DEATH: Window{35106e3 u0 com.asm.NETPOINTBOA/com.unity3d.player.UnityPlayerNativeActivity} 09-28 14:04:24.579: W/InputDispatcher(847): Attempted to unregister already unregistered input channel '35106e3 com.asm.NETPOINTBOA/com.unity3d.player.UnityPlayerNativeActivity (server)'
  7. Hola! En un juego estoy intentando cargar un mapa (Google Static Map) mediante la url que pongo a continuación. El mapa se carga sin problemas en el editor y en los dispositivos Android, pero NO en los dispositivos iOS. No sé a qué se debe. En Xcode aparece el error "unsupported URL". url= "http://maps.google.com/maps/api/staticmap?center="+fixLat+","+fixLon+"&zoom="+zoom+"&scale=2&size=640x640&style=feature:all|element:geometry|hue:0x00ffec&style=feature:all|element:labels|visibility:off&sensor=false&key="+key; He empleado otra url sin aplicar estilos al mapa y sí funciona en iOS. No sé cómo conseguirlo. A ver si me podéis ayudar. Gracias!! url= "http://maps.google.com/maps/api/staticmap?center="+fixLat+","+fixLon+"&zoom="+zoom+"&scale=2&size=640x640&format=jpg&maptype="+maptype[index]+"&sensor=false&key="+key;
  8. Buenas noches. Quiero hacer un Spawn de varios objetos para que aparezcan en varias posiciones aleatorias de tal forma que los objetos aparezcan a la vez al cargar la escena y no cambien de posición hasta que vuelvas a entrar en la escena. Tengo el siguiente código pero los objetos me aparecen uno por uno y no es lo que quiero. A ver si me podéis ayudar. using UnityEngine; using System.Collections; public class SpawnItems : MonoBehaviour { public Transform[] SpawnPoints; public GameObject[] Objectos; void Start () { int spawnindex = Random.Range (, SpawnPoints.Length); int objectindex = Random.Range (, Objectos.Length); Instantiate (Objectos [objectindex], SpawnPoints [spawnindex].position, SpawnPoints [spawnindex].rotation); } }
  9. Buenos días! Tengo un problema con la pantalla de inicio de mi juego. Quiero que aparezca 5 segundos pero no lo consigo. En la versión que estoy haciendo para Android funciona perfectamente pero cuando la compilo para iOS no se detiene esos 5 segundos y desaparece enseguida. Espero vuestra ayuda. Muchas gracias!! Este es mi código: using UnityEngine; using System.Collections; public class CargaPantallaInicio : MonoBehaviour { IEnumerator Start () { yield return new WaitForSeconds(4f); Application.LoadLevel("Menu"); } }
  10. Pero cómo hago un Minimapa sin una render texture en la cámara y una raw image en el UI ??
  11. Este es el resultado de la prueba dibujando sólo la mask y con la imagen. Por cierto, es una Raw Image de 1024x1024. Adjunto capturas y los settings de la Raw Image
  12. Y cómo puedo saber si se mueve con la resolución hacia abajo? Cómo puedo ajustarlo?
  13. De los que he probado: en el xperia s (2gb ram), iphone 5s(1gb ram), iPad mini2 (1gb ram) aparece bien. En xperia z (2gb ram), motorola moto g2(1gb ram) aparece mal. No encuentro coincidencias...
  14. Me pasa con algunos teléfonos, con otros no. Por eso no sé de qué puede ser.
  15. Buenos días! Estoy desarrollando un juego para Android que contiene un mimimapa circular en una de las esquinas. He seguido todos los pasos pero al aplicarle una máscara circular al mapa, en la parte inferior se sale de los límites del círculo. Os dejo una captura para que lo veáis. Esto sólo me ocurre en el teléfono. Cuando lo simulo en el pc aparece correcto. A ver si me podéis ayudar a solucionarlo. Gracias!!
×
×
  • Create New...