Jump to content
UnitySpain

Aceptamos donaciones vía Paypal.

UnitySpain.com es un servicio gratuito, pero mantener la Comunidad conlleva una serie de gastos.

Fondo Anual Unityspain: Donados 15,00€ de 150,00€

  • Servidor: Dominio.com y Hosting Web
  • Mantenimiento de los Foros
  • Contenido y Servicios Extras
  • Mantenimiento para Redes Sociales

Arsen

Fosiles
  • Content Count

    7
  • Joined

  • Last visited

Community Reputation

3 Neutral

About Arsen

  • Rank
    Recién Llegado

Profile Information

  • Especialidad
    Otros

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. @Moand Creo que no me di a entender bien, pero cuando me diste la primera posible solución funciono perfectamente, solo cambie Up por Forward por que con Up los objetos se elevaban, no avanzaban. No hacia falta mencionarlo pero preferí hacerlo por si alguien terminaba en mi publicación buscando alguna solución a algún problema similar. ¡Muchas gracias de nuevo por tu ayuda! .
  2. Muy interesante. @Moand Use la forma que me compartiste, solo que cambie Up por Forward, y ¡funciono! con Up el problema que me daba era que al estar el eje Y arriba las figuras desaparecían. Al final el script quedo de esta forma: { public float speed; void Update() { transform.position += Vector3.forward * speed * Time.deltaTime; } } @lightbug Mas adelante en el tutorial, se menciona de usar el mismo código que mueve el láser, para mover los asteroides, pero con los modelos de los asteroides el problema no existió, me dio curiosidad y realice un ejercicio donde colocaba el script para distintos objetos. Parece ser que el problema solo existe para los Quads. anexo el vídeo donde de izquierda a derecha se encuentra: Quad-Planar-Esfera-nave(jugador no se mueve) sobre la nave esta el laser hecho por un Quad-nave como objeto-asteroide como objeto-Cubo. https://www.youtube.com/watch?v=Ii6aJEqstUI Como verán los únicos que me dan problemas son los quads, anexo las características de los 2 Quads, y la esfera. No se si el problema se deba a algún cambio con las funciones de unity del tutorial al mio. En la imagen se encuentran de izquiereda a derecha: Esfera-Láser-Quad. Muchas gracias por su ayuda, ¡Saludos!
  3. @Gastonspas: Si coloco Time.deltaTime, el láser no se mueve. @lightbug, muy bien estos son los parámetros, no se si tenga que configurar algo, pero desde que instale unity no he modificado nada de allí :
  4. Muchas gracias, guardare la pagina. Parece que sera de mucha ayuda. Muy interesante la simulación de Jack Torrance.
  5. Hola buenas tardes, me encuentro realizando los tutoriales de la pagina ofical de Unity, (Vídeo del tutorial en el segundo de referencia) (Link al tutorial completo) Mi problema es que inserto el código tal y como me aparece en la pagina (Adaptado para unity 5): using UnityEngine; using System.Collections; public class Mover : MonoBehaviour { public float speed; void Start () { rb = GetComponent<Rigidbody>(); rb.velocity = transform.forward * speed; } } Pero no obtengo los mismos resultados, mi objeto de láser tiene otro tipo de movimiento, como si estuviese en bajos frames: (Vídeo a mis resultados) De antemano muchas gracias.
  6. Es mi primer día, buscando información de foros en ingles me tope con una publicación de por el año 2011, y por lo que veo esta web a crecido mucho desde entonces. A día de hoy se prácticamente nada, pero trabajare para poder aprender y en un futuro no muy lejano ser yo quien ayude al resto. Saludos y espero verlos seguido. _________________________________________________________________________ Editado: No tengo idea de por que se publico 2 veces mi presentación, y no encuentro como suprimirlo, si puede eliminarlo algún moderador, o administrador, estaría agradecido. Muchas gracias de antemano, disculpen las molestias que esto pudo ocasionar.
×
×
  • Create New...