Jump to content
UnitySpain
jose sanchez

Error CS0103 con Monodevelop Unity, No consigo resolverlo.

Recommended Posts

Pues basicamente estoy haciendo un curso de C# para unity, por esto de aprender a usarlo, asi que he decidido por empezar por el principio que es como programar en C#.

Tras varios cursos y ejercicios, me ha surgido un problema:

De repente como se ve en la imagen, la mayoria de esos nombres me dan ese fallo, incluso el Debug.Log me da ese fallo, es una locura. He buscado en paginas de internet pero lo que resuelven son errores con referencias a algo en concreto, pero mi problema es que me da error la mayoria de los nombres.

No creo que me haya explicado bien pero espero que se me entienda.

La cosa es, que cuando intento depurar, me da este error:

Error: Build failed. See the build log for details. (Assembly-CSharp)

He reinstalado Unity y sigo con el mismo problema, y repito que no he tocado nada de configuracion ni nada, y en scripts que anteriormente funcionaban pasa esto mismo, ojala que alguien me pueda ayudar.

Dejo esta imagen para daros una idea de como un codigo simple ya me da fallo.

Error Cs0103.jpg

Share this post


Link to post
Share on other sites

si te fijas "using UnityEngine" te sale en rojo, no te encuentra esa "libreria".... 

como MonoBehaviour es parte de esa "libreria".... pues no lo puede cargar, por eso dice:

"el nombre 'MonoVehaviour' no se encuentra en contexto actual"

creo que se te ha des_configurado el editor(monoDevelop)

Share this post


Link to post
Share on other sites
hace 59 minutos, Igor said:

si te fijas "using UnityEngine" te sale en rojo, no te encuentra esa "libreria".... 

como MonoBehaviour es parte de esa "libreria".... pues no lo puede cargar, por eso dice:

"el nombre 'MonoVehaviour' no se encuentra en contexto actual"

creo que se te ha des_configurado el editor(monoDevelop)

Si, acabo de probar con visual basic y todo va bien, así que tiene pinta de eso.

¿Sabes como podría hacer para configurarlo como estaba o por defecto?

Muchisimas gracias.

Share this post


Link to post
Share on other sites
9 hours ago, jose sanchez said:

Si, acabo de probar con visual basic y todo va bien, así que tiene pinta de eso.

¿Sabes como podría hacer para configurarlo como estaba o por defecto?

Muchisimas gracias.

Hola, mira, yo perdí casi la fe por monodevelop, siempre te sale con una nueva, o que son las ISO del legnguaje, o que lo abrís y no cargó algo, que los caracteres pasan de letras a símbolos iluminati, que los colores se cambian, etc.... si decís que te anda en Visual Studio (supongo que te referís a visual studio, no visual basic) entonces te recomiendo que abandones monodevelop. En mi caso uso Visual Studio Code, es un VS pero pensado del lado de Editor de código mas que de IDE, y te puedo asegurar que funciona perfectamente con tu proyecto en Unity, podés incluso personalizarlo como quieras y descargar extensiones relacionadas a Unity... y lo más importante, no tenés que estar 1 día entero instalándolo.

Edited by lightbug

Share this post


Link to post
Share on other sites

dentro de monoDevelop 

entra en poject/ Edit references

y selecciona la pestaña .Net assembly

mira que esten clicados

1512396471710587637727.jpg

1512396296857503977231.jpg

 

tambien puedes ser en unity

en Edit/ preferences

selecciona monodevelop

1512396596111-453446564.jpg

y sino no se...

...pruebar a volver a instalarlo

si quieres poner otro "editor" lo cambias en esa pestaña de unity/edit/preferences...

yo antes usaba "sharp develop"

 

Share this post


Link to post
Share on other sites
hace 5 horas, Igor said:

dentro de monoDevelop 

entra en poject/ Edit references

y selecciona la pestaña .Net assembly

mira que esten clicados

1512396471710587637727.jpg

1512396296857503977231.jpg

 

tambien puedes ser en unity

en Edit/ preferences

selecciona monodevelop

1512396596111-453446564.jpg

y sino no se...

...pruebar a volver a instalarlo

si quieres poner otro "editor" lo cambias en esa pestaña de unity/edit/preferences...

yo antes usaba "sharp develop"

 

Nada, no me deja entrar en project/edit preferences, me aparece en gris y eso que no tengo el modo depuracion activado ni nada de nada, solo acabo de abrir un script antiguo y no me deja. Por ahora voy a intentar usar Visual Studio que ya lo puse en las preferencias de unity y a ver si se me da bien o si me dara mas problemas jaja.

Muchas gracias igualmente a todos por ayudarme.

Igualmente si sabe alguien como arreglar lo de project/edit preferences en monodevelop estaria bien que me lo explicase.

Gracias de verdad.

Share this post


Link to post
Share on other sites

Vale ahora si me deja entrar a Project/Edit Preferences pero tengo todo clicado en la pestaña de .Net Assembly y el problema sigue :( estoy malgastando tiempo con este editor de textos.

Share this post


Link to post
Share on other sites

×
×
  • Create New...