Jump to content

Starfox

Fosiles
  • Content Count

    4
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Starfox

  • Rank
    Recién Llegado

Recent Profile Visitors

326 profile views
  1. He encontrado el problema. Al parecer, tenía conectado un mando para los juegos y afectaba ocasionalmente al movimiento del personaje. Desenchufado el mando, se acabó el problema. Ahora voy a atreverme con las máscaras para ver si consigo hacer que mi personaje apunte mientras anda. Gracias Francoe1 por tu atención. Un saludo, Starfox
  2. He seguido un tutorial. Es para el unity 4x y yo tengo el 5, pero con alguna salvedad debería funcionarme. En las transiciones he desactivado la opción de "Has exit time" y luego he añadido la flotante para la animación de andar y una boolean para la de correr, tal como explica en el vídeo. He estado trasteando un rato y al principio me funcionaba perfecto hasta hace un rato, que ha vuelto a hacer lo mismo. Además, cuando doy al play y abro la ventana del animator, no funciona siempre la barra de progreso de la animación en la que esté el personaje. Raro. Creo que voy a desinstalar y volver a instalar el Unity. ¿Me conserva los proyectos si desintalo? El enlace al tutorial es éste. Gracias por tu tiempo.
  3. Uso las animaciones del Raw mocap. ¿Crees que podría ser la configuración de los root de la animación WalkFwd?
  4. He añadido un biped a un personaje, lo he configurado como "humanoid" y he aplicado una animación walk con mecanim. Estoy usando unity 5.1.1 free. He repasado el script, el animator y todo parece estar bien. El caso es que al dar al play, si pulso la tecla W, mi personaje camina tal y como se espera, pero si suelto la tecla y tras pasar al estado Idle, en ocasiones el personaje vuelve a caminar por sí solo. He usado una variable flotante con los valores típicos del 0,1 para las transiciones del Idle al Walk, y pensaba que podría ser que mi teclado pudiera estar mal, pero si abro el word y pulso la tecla en cuestión no hace nada raro. Tampoco en el script me escribe mal, así que deduzco que debe ser algo de Unity. ¿Podría ser algún bug de Unity? Si alguien tiene alguna idea de qué podría ser se lo agradería. Un saludo. Starfox
UnitySpain © Todos los derechos reservados 2020
×
×
  • Create New...