Jump to content

ST-16

Registrados
  • Content Count

    15
  • Joined

  • Last visited

Community Reputation

1 Neutral

About ST-16

  • Rank
    Iniciado

Profile Information

  • Especialidad
    Otros

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Buenas! Tengo una duda sobre lo que quiero realizar: El sistema de ataque que estoy creando, tengo las animaciones de correr y tal, y luego aparte la de ataque, pero quiero que la animación de ataque solo funcione en el tren superior, de manera que la misma animación de ataque, funcione para el personaje independientemente de si este está corriendo o está parado. Segun tenia entendido, unity tenia una opcion para eso, o para algo parecido, pero no se donde narices esta o como hacerlo funcionar... Gracias de antemano!!
  2. Hola a todos!! Al final consegui solucionar el problema, exactamente no era un problema de pivotes, si no la falta de un hueso en concreto. Consegui encontrar la solución de rebote en un video de youtube, la pongo a continuacion, por si alguno le vuelve a ocurrir este problema! Un saludo!!
  3. Yo creo que ambas animaciones están bien con el pivote, te adjunto imagenes... ya te digo que la única manera que he encontrado es plantandole un hueso más a ras de suelo y configurandolo en unity como si fuera el de HIPS... consigo que se pegue al suelo, pero al correr, se despega unos centímetros casi imperceptible pero si se fija uno se ve.... y no creo que esta solución sea muy practica...
  4. He probado a colocar un hueso a ras de suelo, llamado root, y he unido la cintura a el, (no se si esto se hará así) y lo he metido en unity, y funciona en el sentido de que el personaje ya va a pegado al suelo, pero cuando cambia de animacion de idle a correr, esta ultima va como despegada varios centímetros del suelo, en cuanto para, vuelve a ponerse a ras de suelo.
  5. Que va, en blender eso esta bien, creo que el problema es que uno directamente el metarig con la capa, y lo exporto a unity, y me falta el hueso de root...
  6. Y como se pasa correctamente el pivote de blender a unity?
  7. Vale, me ha vuelto a pasar 😅 creo que ya se cuál es el problema, aunque no se muy bien como solucionarlo. Todos los problemas surgen al pasar el metarig de blender a unity... Que creo que lo hago mal... Porque si utilizo rigs copiados de otros sitios no hay problema pero al usar el metarig de blender vuelve a pasar siempre lo mismo... No sé si conocéis alguna manera de hacerlo compatible con Unity o un tutorial o algo 😅
  8. Perdonad, que he estado unos días de vacaciones, la verdad es que no se cual era el problema.... simplemente he vuelto hacer lo mismo, y parece que ya funciona.... no lo entiendo muy bien que ha pasado, pero gracias de todas maneras!
  9. Que va.. si pongo el pivot donde va, me pasa lo mismo....
  10. Nadie sabe que podria estar pasando?? 😥
  11. Que va, activado o desactivado, hace lo mismo, no hay variación. En teoria, creo, que los huesos están bien... aunque algunos vienen cambiado de nombre desde el metarig de blender, pero me marca que esta todo correcto. Ah vale, bueno la jerarquia y la t-pose del personaje es esta.
  12. Pues a ver... estoy aprendiendo a usar Unity, aun no lo controlo mucho, así que no se muy bien si voy a saber responderte a todo lo que me preguntas, pero lo intentaré 🤣 El pivote en Blender lo situó en el plano entre los dos pies, en unity la verdad es que no se como cambiarlo, está puesto por defecto al importar el personaje de blender imagino. El personaje lo importo, y le dejó solo el clip de T-pose, y luego el resto de animacion las importo por separado. En este caso solo he hecho dos animaciones más (IDLE y Correr) El Rig es humanoide, he usado el human meta-rig de blender. El Unity, si dejo el rig en generic, no funciona, si lo pongo en humanoide, funciona y detecta todos los huesos y la tpose perfectamente. Si el personaje lo dejo en tpose, se queda perfectamente en el plano del suelo, y puedo moverlo en esa posición sin que varíe la altura ni de botes ni nada raro. Pero en cuanto le meto las animaciones en el blend tree, se descontrola, se sube varios metros hacia arriba y corre por el aire y con pequeñas oscilaciones arriba y abajo. En cambio, metiendo esas mismas animaciones, a algún personaje que probé de mixamo para ver si mis animaciones estaban mal o que, funcionan perfectamente, el personaje va y corre por el suelo y mueve las animaciones perfectamente.... A si que no se muy bien donde está el problema... Lo de la jerarquía no se muy bien a qué te refieres 😅 Si necesitas mas info me dices, que no se si he podido responderte bien, que aun estoy un poco verde en Unity xD
  13. Que va, eso ya lo probe, y los personajes siguen flotando y corriendo dando botes por el aire.
  14. Buenas tardes, os comento mi problema, que llevo bastantes días intentando resolverlo y no hay forma... Estoy creando personajes y animaciones con Blender, utilizando rigify, y luego los exporto a Unity. A priori, una vez exportados, no aparecen problemas con el rig y todo parece correcto. Pero el problema surge una vez que meto las animaciones y el personaje en el Character Controller, el personaje se despega del suelo y se sitúa a varios metros de altura del suelo, y después con las animaciones ya se acaba de descontrolar....va dando botes y cambiando de altura. Para probar, utilice también algunos personajes de mixamo, poniéndoles mis propias animaciones, y funcionan perfectamente. Parece que el problema sólo surge con mis personajes, y no parece que este en el rig, porque si funciona con esos otros personajes... No doy con el problema, no sé si esta en algo que importó mal a unity o qué... Muchas gracias de antemano! Un saludo!
UnitySpain © Todos los derechos reservados 2020
×
×
  • Create New...