Jump to content
pioj

Ayuda publicando en Google Play para varios dispositivos

Recommended Posts

Saludos a todos. Me encuentro en una situación algo delicada.

 

Me han pedido que publique en mi cuenta de GooglePlay (la Developer Console) una versión de mi juego para que sea compatible con una serie de dispositivos (móviles Samsung,etc. chip PowerVR).

 

El problema es que ya tengo una versión para Adreno subida que funciona en unos 700 cacharros, y al tratar de subir la nueva, no se añaden, sinó que se sustituyen (y paso a tener sólo 200 dispositivos soportados), perdiendo compatibilidad.

 

Todavía no he probado a crear una Build para ETC1/ETC2, pero no creo que mejore mucho la cosa...

 

 

 

¿Alguien con conocimientos o experiencia en este tema de publicar Apps en Google Play podría ayudarme, por favor?

 

¿Se pueden incluir varias versiones dentro de una misma aplicación publicada? ¿Cómo se gestionan?

 

¿Qué puedo hacer para asegurarme de que mi juego está soportado por la mayor cantidad de dispositivos posibles?

 

 

 

Muchas gracias. Corre cierta urgencia.

Share this post


Link to post
Share on other sites

A ver.. Texture Compression -> Don´t  Override.  Con esto tendrás compatibilidad con la mayoría de dispositivos ( unos Ocho mil y pico)

Share this post


Link to post
Share on other sites

Gracias por la idea.

 

¿Alguna otra cosa que deba tener en cuenta, o con eso ya os vale a la mayoría?

Share this post


Link to post
Share on other sites

@pioj yo con ETC2 consigo compatibilidad con 8845 dispositivos, teniendo en cuenta que la api minima que uso es 2.3 y nunca e ha salido ningun aviso de que los haga compatibles con PowerVR ni nada.

Share this post


Link to post
Share on other sites

De momento está solucionado forzando a que no use ninguna compresión de texturas. Por desgracia, es obligatorio indicar API 4.0 ó 5.0 estos días...

Share this post


Link to post
Share on other sites

De momento está solucionado forzando a que no use ninguna compresión de texturas. Por desgracia, es obligatorio indicar API 4.0 ó 5.0 estos días...

@pioj lo que pasa que supongo que si no lo comprimes ocupara mucho mas espacio no??

 

Como que es obligatorio poner api minima 4.0 o 5.0?? Si haces eso el juego no sera compatible con versiones anteriores de android y aunque no son muchos, aun hay una cantidad importante de gente que lleva un telefono con gingerbread 2.3

Share this post


Link to post
Share on other sites

@AdrianMadu, digo yo que tendré mis propios motivos para obligarme a hacerlo sólo compatible con ciertas versiones, ¿no? En mi caso (como bien indico en el topic inicial), es el cliente quien me pide que sea para los últimos Samsung y móviles que hayan salido. Eso excluye automáticamente versiones por debajo de la 4.3.x

 

Respecto a la compresión de textura, el juego acaba ocupando lo mismo, 16MB; no viene de 200kb más.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

UnitySpain © Todos los derechos reservados 2020
×
×
  • Create New...