Jump to content
chessjose

Problema al compilar el juego

Recommended Posts

Buenas!

El problema que me sale no lo entiendo por que la consola me dice donde esta el error y voy a la zona donde esta el error y veo que esta bien y que lo que me dice no hay ni el ;  y encima no falta ya que esta en un cierre de estos }. Como os pongo en las imágenes a ver encontráis el fallo por que yo no... 

Todo esto es cuando intento hacer el .exe

 

consola.PNG

Captura2.PNG

Edited by chessjose

Share this post


Link to post
Share on other sites

Hola @chessjose,

no te aconsejaria hacer eso ... exponer un problema que tienes, y al cabo de un rato volver a escribir diciendo simplemente "Solucionado" sin molestarte en comentar que has hecho para solucionar el error.

En primer lugar por respeto al resto de compañeros, puede que detras tuyo venga otro con el mismo problema ... y despues por tu propio interes, puede que vuelvas a pedir ayuda (no seria raro, llevas 2 dias en el foro y has pedido ayuda 2 veces) y viendo que no ayudas en lo poco que podrias luego el resto de compañeros no se molesten en ayudarte.

Pero como decia es solo un consejo, despues puedes hacer lo que quieras :10_wink:

Share this post


Link to post
Share on other sites

ok, pues lo primero pedir disculpas por no haber pensado en ello, 

el problema era que me pedía ( ; )  y yo estaba siguiendo el tutorial de mi profesor y lo tenia copiado tanto que para mi era un plagio en toda regla xD  y el no la pone, pero al intentar hacer el .exe me saltaba el error que hay en las imágenes, 

solo puse el ; antes de la llave } y listo 

eso fue todo 

vuelvo a reiterar mis disculpas

Share this post


Link to post
Share on other sites
hace 13 minutos, chessjose said:

ok, pues lo primero pedir disculpas por no haber pensado en ello, 

el problema era que me pedía ( ; )  y yo estaba siguiendo el tutorial de mi profesor y lo tenia copiado tanto que para mi era un plagio en toda regla xD  y el no la pone, pero al intentar hacer el .exe me saltaba el error que hay en las imágenes, 

solo puse el ; antes de la llave } y listo 

eso fue todo 

vuelvo a reiterar mis disculpas

Aunque tal como lo tienes es lo mismo, el ; lo tienes que poner en Application.Quit(); . Sino si añades otra linea después de esto volverás a tener el mismo error.

Saludos

Share this post


Link to post
Share on other sites
hace 18 minutos, chessjose said:

No, no me da ningún problema xD. y lo tengo así.

 

 

Captura3.PNG

 

Da igual que no te de ningún problema, está mal y no quiero ser borde, pero duele solo de verlo. Si no te da ningún problema es porque después del #endif no hay ninguna linea adicional, si la hubiera te volvería a dar el mismo error. El punto y como debe ir al final de la linea del Application.Quit(), los puntos y coma siempre van al final de la linea...

Saludos

Edited by TheBullet

Share this post


Link to post
Share on other sites

UnitySpain © Todos los derechos reservados 2020
×
×
  • Create New...