Jump to content
Null

Shading extraño entre objetos 3D

Recommended Posts

Hola, cómo están?

Por casualidad alguien sabría decirme por qué ocurre ésto entre mis objetos 3D, en este caso la carretera?
Nótese la raya negra que hay casi en el centro de la imagen:
374ad00906796790e3b9e5f7cb26a586.png

Estoy siguiendo el diseño modular para crear cosas como la carretera y los edificios del juego...
pero si se va a ver ese extraño borde oscuro cada vez, pues como que me preocupa.

Alguien sabe? :o

Share this post


Link to post
Share on other sites

Hola Null, de la imagen parece que la geometría está bien, pero falta más info, como por ej las texturas que usas, que shader usas, bajaste el asset o lo armaste vos? pasa en todo lugar o solo con ese modelo con ese material (incluso con esa iluminación)?

Share this post


Link to post
Share on other sites

Me parece un problema de texturas y posiblemente viene de una del AO.

Seria bueno que mostraras tus texturas aqui para poder comprobar que esta pasando.

 

Share this post


Link to post
Share on other sites

Hola!

@lightbug
El modelo lo hice yo, pero las texturas las tomé de internet. No son definitivas para mi modelo.
En cuanto al shader, estoy usando el shader Standard de Unity en los 3 materiales del modelo (asfalto, vereda y tierra):
https://i.gyazo.com/bf84196f3b9bc42f9ab03d65939e20ac.mp4
 

@juguefre
Actualmente el modelo no está usando ninguna textura AO, solo un par de normal maps.
Estas son las texturas:
bec9b1773d13ef096fec139aceecc6e3.jpg

Estos los dos normal maps:
658999f7bbccbc8008c1dc1c6483208e.jpg

Aquí muestro los ajustes que tiene cada textura:
https://i.gyazo.com/3b6008e0ac0a87fc874602fa4800be78.mp4

Mientras tanto estoy usando el Post Processing Stack de Unity para obtener el AO.
Aquí estoy probando a desactivarlo y activarlo para ver cómo se ve:
https://i.gyazo.com/3af119e9ed6ea9366432217b1319749c.mp4

Y aunque al desactivarlo se sigue notando la línea, tenerlo activado sin duda empeora las cosas.

Estos son mis ajustes de iluminación:
311d6435467e9dbdb486cf2f06a7eeab.png

Los Quality Settings:
d99aee8a3fa2a346dd625b10bac3918f.png

Mi conocimiento de modelaje 3D no es aún tan amplio, pero como dato adicional puedo decir que el modelo no tiene baking de ningún tipo.
Tendrá que ver? Pruebo a crear una mesh high poly y vemos si al hacer el baking se me soluciona?

Share this post


Link to post
Share on other sites

esa "linea negra" es linea de union de las diferentes piezas/modulos? las diferentes piezas no pueden calcular el sobreado como si fueran un conjunto... lo hacen de manera indibidual.... por eso no queda bien la "union".... prueba poniendo los setings de normals/tangents en calculate... y poner un angulo pequeño... 30 grados igual... igual asi se soluciona.... o se nota menos...

Share this post


Link to post
Share on other sites

Parece tema de vertex normals y de smoothing groups. Te recomiendo buscar tutoriales e información sobre el tema por Internet. Manipulando los grupos de suavizado y las normales de los vértices, se consigue cambiar la apariencia de las mallas3D.

normalsrounding.png

 

Share this post


Link to post
Share on other sites

UnitySpain © Todos los derechos reservados 2020
×
×
  • Create New...